can't access get error ERR_NAME_RESOLUTION_FAILED

So, I'm trying to get to the webpage to try to logon and I can't even get to the webpage.  I get an error ERR_NAME_RESOLUTION_FAILED and the page doesn't load.  I have a valid twc id and I can access my account online, but for some reason I can't get to the streaming area.  


I can get to other websites, but for some reason just this website I can't get to.


Time warner online chat help was of no assistance.  They tried, but nothing worked and then I was supposed to be transferred, but got disconnected instead...

Spectrum Employee

Re: can't access get error ERR_NAME_RESOLUTION_FAILED

Sorry to hear about the issues accessing that web page, @cheisler1978.  Are you able to test in a different Internet browser to see if that makes a difference?  Also, please ensure that the latest version of Adobe Flash Player is installed.  That can be downloaded here.


Thank you for your participation in the Forums!


Jeremiah S.
TWC-Social Media Customer Care
Moderator - TWC Community Forums

Check out the community guidelines here

Re: can't access get error ERR_NAME_RESOLUTION_FAILED

are you able to see content on other apps like iOS, Android, Roku, or XBOX?  I'm having similar issues and I can't see any content on any of the previously mentioned TWC apps.  Also, I'm getting "Live TV not available" and "feature not available"


Re: can't access get error ERR_NAME_RESOLUTION_FAILED

I've had the same problem on all platforms since October--no Roku, no iPad, no iPhone, no  I'm about ready to switch to a different provider because the support at the new Time Warner Cable aka Spectrum is terrible--I've called multiple times and chatted online multiple times, and each time, they have me uninstall and reinstall their stupid app on everything. It never works, and I'm getting tired of paying money for something that doesn't work.  


I also noticed this happened at the same time TWC became "Spectrum," so perhaps poor service is the new normal, which is too bad because I've always thought that TWC has been great and never considered leaving before.


Re: can't access get error ERR_NAME_RESOLUTION_FAILED

I myself can get to the web page but it asks me to sign in. I put the correct info there but web page says its incorrect. How do I know its correct you may ask? Well i just signed in on to make this post. I tried to connect using phone on the TWC app and that told me Unable to fulfill my request at this time. So it looks like they are having issues with their authentcating servr

Lead Moderator

Re: can't access get error ERR_NAME_RESOLUTION_FAILED



Are you still experiencing issues now? We had an issue earlier in the day that is resolved. 

If you are still having problems please do let us know by contacting us directly at 



Please include your account number and verification of your username.


Julia R.
^TWC-Social Media Customer Care
Lead Moderator-Community Forums



Re: can't access get error ERR_NAME_RESOLUTION_FAILED

Yup can access it now ty