Constantly connecting to Spectrum Wifi Hotspots

So I had installed the spectrum app a few months back and had installed the profile to have access to the wifi hotspots. Upon use the wifi is actually much slower than lte so i removed the profile and the app but my phone still re-connects to the wifi hotspot. I have checked in the wifi page and there is no "auto-join" tick so i can shut it off. It is very annoying. I constantly will have music/maps cut out while i have the phone mounted in my car since its trying to reconnect to the slow wifi hotspot. This issue is on an iphone XS. Any help would be greatly appreciated. 

15 REPLIES 15
Lead Moderator

Re: Constantly connecting to Spectrum Wifi Hotspots

Just so that we are all clear. On your iPhone you click on Settings then General then profiles.

 

When you go there you are not seeing Spectrum Wifi listed? If the mobile phone a Spectrum mobile phone? 

 

On the Apple support website it shows some steps you may need to take to end that auto join.

 

Join Wi-Fi networks automatically

Your iPhone, iPad, and iPod touch can remember network and login information so that you can automatically reconnect to that network when you're in range.

If your device doesn't automatically join a captive Wi-Fi network, follow these steps:

  1. Tap Settings > Wi-Fi.
  2. Tap  next to the network name.
  3. Make sure that Auto-Join is on.

If you don't want to connect automatically, turn off Auto-Join. To see the Welcome screen the next time that you connect to the network, turn off Auto-Login. 

 

Regards,

Julia R.

Spectrum-Social Media Customer Care

Lead Moderator-Community Forums

 

 

 

 

Seasoned Contributor

Re: Constantly connecting to Spectrum Wifi Hotspots

I know that iPhones will remember any networks they have connected to in the past, even if you've deleted the profile.  When that network either connects, or shows up in the available networks, you'll have to select it and use "Forget network", then it won't auto-connect any more.

I'd imagine that Android has a similar feature.

Cheers.

 

Re: Constantly connecting to Spectrum Wifi Hotspots

I have tried removing the profile and i have went into the wifi settings for specific hotspots its connected to and turned off the auto join selector but it still connects to the hotspot automatically. it seems like its forced to connect. it's a very annoying glitch as my lte is faster and this is a very annoying issue

Re: Constantly connecting to Spectrum Wifi Hotspots

There is no option to click "forget network" in all the spectrum/TWC hotspot Wi-Fi's.
Not applicable

Re: Constantly connecting to Spectrum Wifi Hotspots

PROBLEM was my iPhone WiFi keeps on trying to connect to TWC WiFi Passpoint or Spectrum WiFi even with Auto Join turn off.

SOLUTION Go to your iPhone SETTINGS, then look and open the GENERAL Section and scroll all the way down until you see and open PROFILES section, once inside Remove or Delete TWC WiFi Profile.
Not applicable

Re: Constantly connecting to Spectrum Wifi Hotspots

same problem here, i’d deleted the profile and turn off the wifi auto join, but it still ask for password.
Highlighted
Not applicable

Re: Constantly connecting to Spectrum Wifi Hotspots

i also reset iphone network settings already, but still getting pop up asking to connect the spectrumwifi plus, i’m using iphone 7 plus and ios 12.0.1
Newcomer

Re: Constantly connecting to Spectrum Wifi Hotspots

Same problem here.  The profile is deleted, but it still trys to auto join wifi hotspots.  I see no option to forget the network.  One more reason to drop Sectrum.

Not applicable

Re: Constantly connecting to Spectrum Wifi Hotspots

Has anyone figured this out? Deleting the profile and resetting network settings does not fix this.