Can't use TWC hotspots, No internet

I have followed the steps to connect to TWCWiFi.  Be sure WiFi is enabled on your device. Select the "TWCWiFi" network name from the list of your device's available wireless networks. Open you browser and navigate to a webpage. The sign in portal will appear. Enter your TWC ID and password. Accept the Terms of Service. Click Sign in to finalize the connection. 


I get "Connected, No Internet" The portal page does not appear.


I've not been able to use TWC hotspots since November.

TWCWiFi-Passpoint will tell me the hotspot is out of range, even if I have excellent signal.


I also tried connecting without the finder app, by following the instructions given in this forum.  With the non-passpoint I still get the same thing, connected, no internet, and no portal page.


With the passpoint one, where in the steps it says "your native sign in" will appear... There it wants me to choose a certificate and a domain, which is not mentioned in the instructions.


I'm at a loss as to what else to try.


Re: Can't use TWC hotspots, No internet

Welcome to an uncaring Spectrum.  I have called over a dozen times.  I been told that i would get a call from a higher level tech but it never happens.  I downloaded the HotSpot profile that is purported to automatically connect me multiple times.  It doesn’t work.  I go to multiple HotSpot locations and no one gets connected.   Good luck if u get anywhere.  I’m ready to call FIOS up and switch.  

Lead Moderator

Re: Can't use TWC hotspots, No internet

@Rangers_Fan @Blueh2o


When you are calling are you phoning our WiFi Hotspot group or general

support?  888-851-9350 is the number for our Hot Spot team.



Julia R.
Spectrum-Social Media Customer Care
Lead Moderator-Community Forums



Re: Can't use TWC hotspots, No internet

This doesn't work for my tablet, either.  I suspect something got broken or misplaced either during the transition from TWC  to Spectrum, or when my own plan was changed to a Spectrum plan.  I've removed my devices and re-added them, that didn't help either.  There's just no portal page anymore.  I've tried the spectrum hotspots, no luck there either.  (Why is it still 'TWC' wifi finder?)