Can't connect to open or secure Passpoints

I have been trying for weeks to use TWC's passpoint hotspots, and they never connect. CableWifi, TWCWifi, and TWCWifi-Passpoint will not let me connect with my iPhone 6 (iOS 9.1 beta). Don't tell me it's because I'm on beta.


I've tried using the Wifi finder app to download the passpoint profile; that doesn't help. I've tried deleting the profile and logging into the secure passpoint with my twc id/pass, that doesn't work. I don't get any errors, it just times out and won't connect.


I have standard internet, but my MyWiFi page says "you need standard internet to use these passpoints". I saw another post on here somewhere about people who have higher teirs who are having trouble connecting, also, so I wonder if that's the problem.


I just spoke with an incompetent chat agent who kept telling me to "reboot my device" and "try connecting again", and that "wifi hotspots are designed for specific devices only" (really??? wtf is that???).


I can't connect at any passpoint location, so it's not an isolated issue; it's either my account somehow or it's TWC passpoints.

Everyone's Tags (3)

Re: Can't connect to open or secure Passpoints

Same problem last week with partner wifi hotspot with wifinder and w/o Comcast wifi hot spot, ideas, fellas?
Not applicable

Re: Can't connect to open or secure Passpoints

i have the same problem for 2 weeks and no solutions.😩
Community Manager

Re: Can't connect to open or secure Passpoints

I apologize for the frustration you've experienced with HotSpot's.  If you are still looking for assistance, or are having trouble connecting, you can contact our team that supports HotSpot's.

They can be reached at 1-888-851-9350.



Thank you for your participation in the Forums!

James M.
TWC-Social Media Customer Care
Forum Moderator


Re: Can't connect to open or secure Passpoints

Sadly I got very little help when calling the HotSpot phone number above regarding the same topic. I tried the so called 'live chat' and both times it said I was "3rd in the queue", then "1st in the queue" and then.... NOTHING!!! not even after waiting for 20 minutes!

I figured it out though (at least for my ** NEW ** phone):
The problem was that  my device (phone) was not registered with TWC. I installed TWC's WiFi Finder and the first thing it did was to ask for my credentials. Once I put those in I was able to connect to all TWC WiFi hotspots.


I hope this helps.

Not applicable

Re: Can't connect to open or secure Passpoints

Same Problem here.  I have a MacBook Pro and an Iphone6 and neither will connect to any and all TWC Wifi Hotspots.  I've tried just about everything possible.  Both devices work fine at home with my Wifi from TWC.  But will not work on the road.  Very Frustrating to say the least.


Roger Cann