Not applicable

TV App still not working resolved 3/17

Despite the reports that the interuption has been fixed, my TV app still doesn't work.  While I post this in the iOS forum, it doesn't work on my Samsung Galaxy S5 either.  I get the same "system error".


I have uninstalled and resinstalled the app several times over the past 2 days on each device.  


I often use the app to search for programming and control my set top box.  I also watch programming on my iPad when I sit outside or work in my garage.


I truly hope this issue gets resolved soon!!



Lead Moderator

Re: TV App still not working

@NickM we do not have any additional issues posted with the application. 


Are you able to load the application at all or are you getting an error after logging in?
Can you please let us know what problem you are having.  


Has the cable modem (and router if you have one) been rebooted by unplugging 

the power to them and then plugging them back in? Normally we would also ask that 

you unplug the power to your cable boxes as well and reboot those. 


Please let us know what issues you are having and if the reset of your equipment 

does not help. 


Julia R.
Spectrum-Social Media Customer Care
Lead Moderator-Community Forums

Not applicable

Re: TV App still not working

Julia, Thanks for your reply.


Yes, I have rebooted my modem/router.  My internet works fine including WiFi.  My TV service works fine through the cable box.  I have uninstalled and reinstalled the app several times over the past few days and rebooted the devices.


On my iPad, I can login but only get the settings page.  I see Version 5.3, my user name and my cable box ID.  If I attempt to navigate to the other tabs, I get the error.  The app remains logged in.  If I relaunch the app, I immediately see the error and land on the settings page.


On my Samsung Galaxy S5, I login and see the error immediately.  The only option is OK, then I go back to to my home screen.  It does not remain logged in.  I've tried this on WiFi as well as 4G (Verizon).


It all worked fine a week ago.  When I checked the app stores for updates I saw one was the Spectrum TV app.  I upgraded my iPad and phone.  It has not worked since.  The upgrade may be just a coincidence.


Last Thursday I contacted Support over Chat.  They told me of the interuption and said I had to wait it out.


I can log into the Spectrum site to see my account so I know the credentials are OK.  If it matters, I was a TWC customer and still use my TWC credentials to log in.  Once again, it all worked fine until last week.


Thanks for your assistance.






Re: TV App still not working

reset your cable boxes then the modem again


Not applicable

Re: TV App still not working

This issue exists even if I'm not on Spectrum wifi, such as using my 4G phone as a hotspot.  

Not applicable

Re: TV App still not working

I called into Support this morning.  Issues was escalated to the Internet team.  Then it was escalated to the System Admins.  Apparently something was amiss with my account and my services.  Looks like it got straightened out.  The apps are now working.


Thanks all for your help.





Not applicable

Re: TV App still not working

Also the Guide is also no longer rotating on the following devices:


Nexus 7 first gen

Samsung Galaxy Tab A

Samsung S5


It used to work when it was TWC branded.

Not applicable

Re: TV App still not working

ZPACK, I suggest you start your won thread.  Mine is marked Answered so I suspect few will read this to the end.


Re: TV App still not working

When will the spectrum app be compatible with nexus player?