Spectator

Latest App update will not download said device not supported

Last time I used my Samsung Tablet I was able to watch TV with the spectrum app. Last night I tried to watch and was told to update the app. Well I tried and now being told my device was not supported. How can I get the old app back? Why are older devices being abandoned? Your ad says the app is available on more devices, but that is not true.

1 REPLY
Community Manager

Re: Latest App update will not download said device not supported

The Spectrum TV App on Android requires OS 4.2 or higher.  I've included a link to TV App Troubleshooting that you might find helpful.    

 

For direct support, please contact us at: