Newcomer

Unable to Connect Google Home Mini

I'm unable to add a Google Home Mini to my Spectrum Wi-Fi.

 

I complete the setup process via the Home app properly, but it tells me that it can't "communicate with the device" on the network.

 

I've tried various troubleshooting posts I've seen online (it seems like this is affecting a good number of Spectrum customers... there are a handful of recent posts on Google Support), contacted Google Support (they say it's Spectrum), and contacted Spectrum Support (they say they've never heard of such a problem & sent me a link with Google's standard instructions to install).

 

Things I've tried so far:

  • Changing the name of one of the two networks (I have a 2.5 GHz & a 5.0 GHz)
  • Connecting to both the 2.5 & 5.0 networks
  • Ensuring my router settings are in line with Google's recommendations, including disabling AP Isolation
  • Hard resets of routers, Google Home Mini

 

Does anyone have any suggestions or fixes here?

 

- A very frustrated customer

2 REPLIES
Proven Sharer

Re: Unable to Connect Google Home Mini

First, the SSID or "network name" of your 2.4 GHz and 5 GHz WiFi should be exactly the same, except for adding the suffix -5G to the name on the 5 GHz radio.  This allows devices to hop between bands without dropping the signal and finding a new network.

 

Apparently the folks who are complaining over on Google Support don't bother to post their questions or comments about setting up Google Home Mini units using the GHM app here on the Spectrum peer-to-peer user forums. 

 

What is the make and model of your cable data modem?  Did you buy both boxes or get them from Spectrum?  What speed package are you subscribed  to? NOTE:  If you are using a combo modem-router-WiFi provided by Spectrum AND the  Google Mini requires a non-standard port assignment in the router, you can expect setup issues. 

Not applicable

Re: Unable to Connect Google Home Mini

Same issue here.  I called Google support and they stated there is a known problem with the Spectrum supplied Askey router an GHM. The only workaround was to exchange at local store for different manufacture, however when I did that, my local only had Askey in stock. 

 

As as a result, I haven’t even tried to connect to my nest products! 😡