Not applicable

Remote Desktop with Technicolor TC8717T Spectrum Modem Router

After installing this router I lost ability to connect via Remote Desktop,  (RDP)

My target computer is a PC and remote desktop is setup and has its ip address fixed.

I'm using Microsoft RDP software.

In the advanced settings of the router I set TCPand UDP to forward to port 3389 as instructed in the Microsoft instructions for RDP.

When i try to log in from remote it i get a popup message that says That my communication was terminated by host.

 

Spectrum tech support told me that their policy is to not support this effort.

 

Any helpful instructions that any one has found to overcome the RDP problem?

 

3 REPLIES 3
Highlighted
Contributor

Re: Remote Desktop with Technicolor TC8717T Spectrum Modem Router

You might have a look at this:

https://support.microsoft.com/en-us/help/2477133/remote-desktop-disconnected-or-can-t-connect-to-rem...

or this:

https://support.microsoft.com/en-us/help/186645/troubleshooting-rdp-client-connection-problems

Also check your windows advanced firewall settings to ensure that port 3389 is open.

Just as an aside......hackers routinely use bots to search for open ports like 3389 and then use brute force attacks....If I were doing RDP over the internet I would do it through a VPN connection for security purposes. 

 

How do you have the TC8717T firewall set? Maximum(High)? you might consider lowering that and see if that helps. First to Medium then to low. 

Make sure UPnP is enabled.

The host  pc cannot be in either sleep or hibernation mode for RDP to work. So you should have them disabled on the remote pc.

 

Let us know what works for you? 

 

Proven Sharer

Re: Remote Desktop with Technicolor TC8717T Spectrum Modem Router

If you have previously used a specific model of modem that did support RDP, AND IF it is on Spectrum's list of approved devices, you can purchase one (and a separate router with WiFi). You'll be responsible for installation, programming, and maintenance. 

I will second the comment from rocketjetz about hackers using bots to search for widely used port numbers. Keep your firewall security settings as tight as possible.  And I think the "no sleep, no hibernate" rule applies also to the host CPU.

Contributor

Re: Remote Desktop with Technicolor TC8717T Spectrum Modem Router

yeah I meant host not remote so I edited it. thanks for pointing that out. I get turned around sometimes between host and remote..i call them home(host)  and remote