Helper

ARC Problem

I have searched various sites and forums trying to find an answer to this problem that started about a month ago and I have and am hoping someone here might have some insight.

 

I have a TV connected to my receiver via HDMI ARC. When I turn on the TV it turns on the receiver but always changes the input (ARC is set to the TV input but about 2 seconds after it comes on the input switches to Video 2 or Phono). I have tried various cables, setting the ARC input to something else and it always switches to a different random input.  Has anyone come accross this issue? It could be the receiver going bad or the TV ARC signal is jacked.

5 REPLIES 5
Expert

Re: ARC Problem

do both devices have the latest firmware?

Have you tried googling the receivers model + "ARC issue"?

I don't like the way ARC works, it may be resending a string from the remote you're using and it's misinterpreted, especially with the sequential IR code sent from the TWC remote's system on/off button.

I assume you're trying to use the TWC remote, and if you're using one that has a "system power" button, that function is jacked and goes out of sync on devices, don't use it.

turnon/  off devices individually, see if problem reoccurs.

Helper

Re: ARC Problem

I've done extensive research and this was my last hope that someone here would be familiar with this issue.  The system is set up using a Tivo, not the TWC remote or box, with all devices connected to the TV via HDMI, then one HDMI going from the TVs ARC to the receiver's ARC. When I power on the TV the receiver is set to turn on automatically when it detects a signal and is supposed to default to the last used input, which is 99% of the time the TV input, which it does for about 2 seconds before randomly switching to something else.  Once I manually switch the input back to the correct one it will stay there until I turn the tv off and back on again.

 

This setup worked great until last month. Nothing changed. The receiver is an old Sony and no new firmware is available. The TV has the latest firmware update.

Expert

Re: ARC Problem

See if the tivo or blu ray has ARC turned on, turn it off. I've seen DirecTv boxes route thru tv's and mess with ARC devices.

See if the Sony will have a setting for ARC on only one port, set that to the receiver connection only.

Try a different HDMI cable.

 

Are the inputs it's randomly switching to have audio on them?

This may be a Sony issue...

 any idea what changed when this started up?

 

Helper

Re: ARC Problem

I've tried multiple cables, the receiver's ARC setting is set to the input I want, the TiVo has no ARC/CEC setting, and the blu-ray ARC is turned off.  The inputs that the receiver randomly switch to have no audio. The only connection is from the tv arc to the receiver arc. Nothing changed in the set up.  

 

My only two conclusions at the moment that can't be tested unless I replace equipment is either 1) The TVs ARC signal has an error or 2) The receiver is not reading the signal correctly. 

Highlighted
Helper

Re: ARC Problem

Over the weekend everything started working as it should on its own without me changing any settings. When I turn on the tv, the receiver turns on a few seconds later and stays on the correct input. I wonder how long this will last.