Newcomer

technicolor TC8717T 2.4ghz connection trouble.

Hello,

I cannot connect to the 2.4Ghz wifi connection on my technicolor TC8717T router.   Each time it says "invalid password" but I've checked the password in the Admin tool and it's exact.   I've changed the password several times and reset the modem several times.   Always the same error.   The 5Ghz works fine.

Any ideas?

2 REPLIES 2
Proven Sharer

Re: technicolor TC8717T 2.4ghz connection trouble.


@Eric3 wrote:

Hello,

I cannot connect to the 2.4Ghz wifi connection on my technicolor TC8717T router.   Each time it says "invalid password" but I've checked the password in the Admin tool and it's exact.   I've changed the password several times and reset the modem several times.   Always the same error.   The 5Ghz works fine.

Any ideas?


Here are some comments:

1)  The admin password on Spectrum-owned devices is usually locked and not editable.  It will quickly (within a few minutes) be forced back to the mandatory one by the cable network management system.

2)  The password for the WiFi connection is NOT the same as the modem/router's Admin password. 

3)  Also check the SSID name you entered on 2.4 GHz - many devices do not allow different SSID names.  For those types it should be exactly the same as on the 5 Ghz side except without the " -5G " suffix characters. 

4)  Good security practices say that you should not be able to view or edit the modem or router management passwords using the WiFi connection. 

Valued Participant

Re: technicolor TC8717T 2.4ghz connection trouble.

When I got my TC8717t modem, i tried to login to the  web based gui to change  my SSID/wifi passwords  and the sticker on the bottom of the modem didn't work.....at all.. So I had to get online and research what  default passwords would work and I found a combo that did allow me to use the webgui to change the SSID and wifi passwords to what I wanted.  I would set the wifi SSID and passwords  back to their default values by resetting the TC8717t, so everything goes back to factory resets and then start all over again.  It may not be approved security but I used the same password for each SSID, I just changed the names of the SSIDs. I might add that I've been an Insight/TWC/Spectrum customer in 4 different cities and 2 states in the past 25 years and I have always changed the administrator account and password and they never reverted back to whatever the defaults where unless  I factory resetted the modem.  hth  If you don't have a manual to your router here is one:

https://d15yx0mnc9teae.cloudfront.net/sites/default/files/technicolor-tc8717t-userguide.pdf