cannot connect to Apple App Store and iTunes from new iPad - SUCCESS!

Just finished setting up my new iPad and it wouldnt connect to Apple's App Store or iTunes. Spent hours with their tech support doing multiple resets and restores. When nothing worked, the guy suggested going to a totally different network connection and trying to do it there because everything with my iPad, my accounts, and their stuff was all working properly, so it had to be something on my end. This seemed kind of sketchy, but lo and behold it worked!


When I got back home, I still can't connect to the App Store or iTunes from my ipad, but thats OK for now. However, Facebook and Twitter arent updating for me, checked my phone, and they're updating there just fine.


So I went into my router and allocated a specific IP addy for my new iPad, rebooted the router, etc...  Then I went and signed out of my old iPad and reset and erased it.




I'm not sure when it actually happened, but after doing the IP addy, rebooting the router, then signing out of and wiping my old iPad, I can now connect to the App Store and iTunes. And my Twitter feed is up again.  FB seems to be working, because I was notified that someone commented on a photo I was tagged in.


Anyway, that's what I did.  Hope anything and everything helps.


Re: cannot connect to Apple App Store and iTunes from new iPad - SUCCESS!

One of the issues we see is that some devices see lan IP adys of to .10 as invalid user class. DHCP start of or 192.168.1 .100 seems to fix them.