Highlighted

T3-T4 Timeouts

Modem: SB6141
100Mbp/s (internet only)
99163 Pullman WA

The last 30-45 days have been a nightmare for me when it comes to internet stability..
Modem logs filling up with T3 escalating to T4 timeouts, typically 5-10 times a day. Sometimes more. Let’s just say the Modem Uptime has rarely been >2 hours..

Initially my Downstream Power Level was hovering ~ -6dBmV, SNR~35dB for each channel and Upstream Power ~ 50dBmV.

Found that these levels may be an issue as sometimes the upstream would be closer to -10 and downstream pushing above 50 when I’d get T4’s.
I went outside with a laptop and checked the signal directly off the line, which (at that specific time) was good:
Upstream PWR 0 +/- 1.
Downstream PWR 44 +/- 1

The direct line was being fed through a 2way splitter -> ~10 inches of RG6 -> 3way splitter(-3.5dB) -> House coax fed to upstairs bedroom -> Modem.
So I swapped a couple connections to place my modem after the 2way.

My Downstream has consistently been better: ~ -5dBmV(SNR:37-38)
My Upstream has also been better hovering ~ 46dBmV.

I am still constantly getting T4 timeouts. I’ve replaced the coax receptacles in my bedroom with new ones and tried a brand new RG6 cable(6ft). Signals directly after a T4 timeout remain good(as far as I know) and are what I listed above for each channel.

Is there anything else I can try that I may have missed? Modem was supplied by Spectrum when we upgraded to 100MB ~2 months ago btw.

Any help would be appreciated! Would like to have everything on my end done before I call in a tech to essentially verify the data I’ve been collecting.
I work at SEL in Production Troubleshoot and have good working knowledge of electrical risks, etc. so don’t hold back!
Thank you,

-RHT
9 REPLIES 9
Helper

Re: T3-T4 Timeouts

It would be interesting to see if you still get those T3 or T4 timeouts while connected to the main line bypassing the splitters and your in- house wiring. That would at least rule out a big chunk of the puzzle.

 

Having the modem behind a 2 way and a 3 way splitter did indeed degrade the signal too much, as you discovered by moving the modem to the main line and behind the 2 way to test. Did you also replace the coax in the walls, attic, crawlspaces? Sounds like you might have a hungry squirrel.

 

 

Proven Sharer

Re: T3-T4 Timeouts

Your cable swapping took you in the wrong direction, and you have reversed the definitions of upstream and downtream.  'Better' is to make the upstream (US or transmit) value lower (ALWAYS below +51) and downstream (DS or receive) level to be higher (within a range of -8.0 min to +10.0 max).  

The modem should always be connected as close as possible to the incoming drop cable signal, preferably using no splitter, but a single 2-way split between modem and TV is usually OK.  Moving your modem's cable to the verry first 2-way splitter was the correct change to make. 

A T3 error message says that your modem stopped receiving the downstream signal for up to three seconds, while the T4 error messages mean the outage was longer than 3 seconds, forcing the modem to reset and scan again for the downstream channels, possibly with a new channel list. 

To fix T3 and T4 errors requires checking the cable path from the modem back toward the node and CMTS.  Make sure all your indoor cable connections are more than just finger-tight and not wet or corroded.  Also be sure the grounding block is connected to the powerline ground near yuour electric meter.  The Spectrum home service tech will check the ones on the drop cable outdoors, whether it is buried or overhead.  

Re: T3-T4 Timeouts

Thanks for a reply reds91185! It is possible that a squirrel (or maybe the cats that take shelter in my crawl space) have messed with the coax. I shouldn’t rule that out, thanks for the reminder! I sort of took my results (after the change I made) as confirmation that the in-house wiring was good based on the small loss (US/DS/SNR) when compared to the values directly off the line. Considering it’s about 60ft of coax from the 2way splitter to my Modem. I will try leaving my modem out there for a few hours(maybe overnight depending on weather and if I can shelter/secure it) this weekend and try that out. I was slightly worried that without some damping and attenuation of the signal(ie house wiring/splitter) that there could be an increase in noise. But at this point, any damage done just means I get all new equipment!

Re: T3-T4 Timeouts

Karl,
I must have written something incorrectly then. I am aware that US is the Modem pushing back to headend and downstream is coming to Modem. The strange thing is that I’ve checked these signals right before my modem T4’d and it all looks within reason. (ie. US: ~45dBmV/channel, DS: SNR: ~37, PWRLVL: (its always negative) -5.

Before I bypassed the 3way splitter, I was noticing US much closer to 50, sometimes 51,52. And DS PWR much closer to -10, sometimes =-10.
I just now caught a screenshot of my logs RIGHT before a T4 occurred. Noticed one US channel’s Ranging Status said (T4 TimeOut) and that my Modem was pushing 51-52dBmV/channel. I’m assuming this was my modem not getting a response and increasing its output as much as it could.

I will check ground connection at the drop and will also try bypassing the 2way splitter as well tonight, considering the only device connected to coax in my house is the modem.

Thanks for the T3-T4 info! Had no idea time was the factor there. I thought it was x amount of T3’s caused the T4.

Re: T3-T4 Timeouts

Alright guys, sadly.. it may have been that -3.5dB 2way splitter. I will get the model tomorrow and post it. I’m not getting my hopes up yet.. but my Modem Up Time is over 6 hours! Ever since I went out and connected directly to the drop(connected coax that feeds into bedroom where modem is) .

My Downstream stats look amazing and have not changed since I direct connected.
My Upstream stats look amazing, too! My modem finally gets to relax and cool down a bit.
Below you will find my stats as of right now, sorry for the formatting, I tried to clean it up a bit.
—————————————————————
Downstream Bonding Channel Value

Channel ID 9 10 11 12 13 14 15 16
Frequency 663000000 Hz 669000000 Hz 675000000 Hz 681000000 Hz 687000000 Hz 693000000 Hz 699000000 Hz 705000000 Hz

Signal to Noise Ratio 37 dB 37 dB 37 dB 37 dB 37 dB 37 dB 37 dB 37 dB

Downstream Modulation QAM256 QAM256 QAM256 QAM256 QAM256 QAM256 QAM256 QAM256

Power Level
0 dBmV 0 dBmV -1 dBmV -1 dBmV -1 dBmV -1 dBmV -1 dBmV -1 dBmV

Upstream Bonding Channel Value

Channel ID 10 12 11 9

Frequency 24200000 Hz 37000000 Hz 30600000 Hz 19400000 Hz

Ranging Service ID 15478 15478 15478 15478

Symbol Rate 5.120 Msym/sec 5.120 Msym/sec 5.120 Msym/sec 2.560 Msym/sec

Power Level 41 dBmV 43 dBmV 43 dBmV 40 dBmV

Upstream Modulation(formatting here sucked and data not important; removed)

Signal Stats (Codewords) Bonding Channel Value
Channel ID 9 10 11 12 13 14 15 16
Total Unerrored Codewords 973839786 973851154 973832568 973858679 973824713 973821715 973822983 973827618
Total Correctable Codewords 2345 1648 1491 2555 1712 1282 991 336
Total Uncorrectable Codewords 1651 1353 1443 1478 1427 1570 1564 1432
Sharer

Re: T3-T4 Timeouts

Hmmm... may be just a bit **bleep**, but those error rates concern me if you are talking just a 6 hour window... or even just overnight or a day. Unless they are just a carry over from before.

It can take a whole weekend to see them break 3 digits on my line when things are good... up to a week to hit 4 digits. Might still be something a bit off upstream from your house's wiring if it was reset to 0 counts after swapping things out.
Community Manager

Re: T3-T4 Timeouts

@Robert_Tompkins

 

I was able to locate your account based on your registration information.  Current signal levels are good and  from our diagnostics, I can confirm that the current uptime (without an interruption) is the longest it has been in six weeks.  If you see the issue return, then we recommend a service call.  To set up a service call, you can contact us by private message @Forums_Help or you can contact our Social Media Customer Care team:

 

Twitter: @Ask_Spectrum
Facebook: https://www.facebook.com/Spectrum

Re: T3-T4 Timeouts

@RAIST5150

Yea, those logs are carry over. I should have reset during the swap but was on my lunch break and was in a hurry!

I will reset sometime today, right now just enjoying the Internet I’ve been missing out on. Part of me is afraid to unplug anything with how great it is right now haha. But hey, if what I did truly solved the problem, I shouldn’t have issues after the cycle.

Re: T3-T4 Timeouts

@James_M

Thanks for taking the time to look into this!
6 weeks sounds about right! If I can confirm that the 2way splitter was originally supplied by Spectrum and is just degraded due to normal use, I will look into getting someone out here to replace it.

Thanks everyone for your help and input! I will accept the faulty/corroded splitter as the solution this weekend after rebooting and reviewing the packet errors after that.
The splitter (visibly) seems fine, but previous homeowners did not have any of this in a box and left it all dangling. So weather(wind, snow rain, sun) may have caused the degradation.