Highlighted
Rookie

SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

As the subject indicates, I have an issue with my SB6190 modem (on the Spectrum approved modem list for 400Mbps service) getting the full speed of my service.  The modem consistently gets around 250Mbps of download speed on 400Mbps service.  The wierd thing is that if I reboot the SB6190 I will get over 400Mbps download speed for about 10 minutes and then it drops back to a consistent 250Mbps download speed.  Any ideas as to what is going on?  Would a new DOCSIS 3.1 modem (in lieu of my current DOCSIS 3.0 modem) solve the problem?

 

IAW with the data posting sticky here are my particulars:

- Zip Code of service: 28150 (Shelby, NC - near Charlotte)

- Type of home: Single family home

- Spectrum Services: 400Mbps Internet Service (Internet only - no other services)

- Make/Model of Modem: Arris Surfboard SB6190

SB6190 speed test.jpg

 

 

 

 

 

 

Additional information:

- Modem firmware: 9.1.93V

- Coax connection: RG6

- Spectrum equipment information page on my account:Spectrum Modem page.jpg

 

 

 

 

 

 

 

 

 

- Downstream/Upstream information:SB6190 stats 1.jpg

 

10 REPLIES 10
Helper

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

How are you testing and with what device? Wired directly to the modem, wired to the router, or wifi?  Any other services or devices running on your network when running tests(icloud backups, antivirus scans, video streaming, Ring doorbells or Nest thermostats)?

 

Have you checked all coax connections back as far as you have access to the street or alley for loose connectors, signs of damaged coax, corrosion, etc? SNR is near perfect but the downstream power is on the high side. Are there any splitters or amps anywhere on your line?

 

A new modem will likely not fix a connection issue. You'll probably get some responses blaming the modem because it uses a Puma6 chipset but I used this very modem on 400 with no problems whatsoever.

Rookie

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

Hmmm... your post got my juices flowing as I had not tested the connection coming directly off the modem.  All my testing was being done through my TP-Link Archer C7 (V2) gigabit router.

 

So I've done more testing based on your comments.  Plugging my computer straight into the SB6190, I am consistently getting more than 400Mbps download speed as determined by the Spectrum Internet Speed Test website.  Once I plug the SB6190 back into the Archer C7 router WAN port and my computer back into a gigabit LAN port on the Archer C7 router (CAT 6 cabling used throughout all connections), I get 400Mbps for about 10 minutes and then it drops to a consistent 250Mbps. 

 

Based on this testing it appears the drop is occurring in the Archer C7 router and not the Arris SB6190 modem.  So the good news is that the SB6190 appears to be working like it should with all the cable connections coming to the house being "good".

 

I've done some more testing on the Archer C7 router throughout the day and sure enough - every time I unplug/plug the SB6190 from the Arrcher C7 WAN port, I get about 10 minutes of 400Mbps speed followed by a drop to a consistent speed of 250Mbps.  All speed checks are being done via the Spectrum Interent Speed Test website.  

 

I don't have anything else plugged into/running through the Archer C7 router that could cause this kind of speed drop, so I'm fairly certain the drop has something to do with a router issue/router setting or router handshake issue with the SB6190.  Will have to do some more research to see if anyone else is experiencing this kind of speed drop with the Archer C7 router.

 

Just for reference, anyone have some recommendations on a good gigabit wi-fi router in case I end up replacing the TP-Link Archer C7?

 

 

 

Sharer

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

May want to look at some of the nicer Asus routers... AC1750 class or higher. New models will come with a 2 year warranty. Decent options in their GUI, and most will support at least Merlin or another form of WRT if you want to get even more features. And their wifi is usually pretty strong.

Here is a link to their recent demo gui if you want to see how it is laid out. The interface is basically the same for most of them (WTFast models are different)

http://demoui.asus.com/

Bought one of those C7 models on sale back around Thanksgiving... took it back for a refund a few days later. Wifi just wasn't worth a flip. Kinda sad really, as the Asus I was going to replace was their original AC1750 design that went to market before AC was really adopted (RTAC-66R ver. A1, made in 2013).

The whole reason I tried it was because the over 5yr old Asus was starting to run hot and was afraid it was about to konk out on me. I notched back power to 50% and stood it up for better air flow (has a stand so you can also set it up vertically) and it was actually still getting better performance than the new C7!

That darn Asus just refuses to throw in the towel. Still have the Best Buy receipt from Feb. 2014... it has been running 24/7 for almost 6 years now.

Safe to say, I got my $170 worth out of this beast....
Rookie

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

Funny you should mention ASUS - I started looking at alternatives yesterday and the ASUS AC86U has caught my eye.  I really like the concept ASUS has put together of their AiMesh network as I have been wanting the option to put in a mesh network with a fully functional router.  Seems that most vendors selling mesh network devices are going for "ease of use/installation" by simplifying and limiting the mesh router settings.  That is probably best for the market as a whole but I'm one of those people that likes to be able to configure my router settings to meet my specific needs. 

 

I know a lot of folks bash TP-Link but i've had really good results with their networking equipment over the years.  My Archer C7 is an early generation (i.e. V2 - they are on V5 hardware now) and even though it has been very reliable (except for this 400Mbps drop to 250Mbps issue), it is probably time to retire it.  So while I have been using TP-Link equipment for well over 10 years, I think I'm going to give ASUS a try.

Helper

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

Do you have any QoS, data limiting, traffic flow optimizer, etc. active in the router settings? Before you return the router you might reset it to factory settings and see if you still have the same results. If all is good then you can adjust the settings one step at a time back to however you want it personalized until you hit the setting that is causing the problem.

Sharer

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

Yeah... think that 86 may be the one I started looking at too. The WTFast one. One free account you can assign for one device (like my PS4). It ran neck and neck with the comparable Nighthawk in some lab testing I saw.

There is also a line of Netgears that have the lightweight NetDuma OS on them... x400 series and up, or something like that? Early releases had some issues, but they should have gotten them streamlined by now. May be worth looking for some recent reviews/testing on them as well.

Pricewise the two designs are pretty close... just depends if you want to try geofiltering (Netgear/DumaOS) or the VPN route (Asus/WTFast). Both camps did a great job in the labs under sustained gigabit LAN benchmarks and wifi testing (though Asus tends to fair a bit better at really long range wifi).
Seasoned Contributor

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

Just for reference the wifi alliance just annouced 6Mhz on wifi6 calling it wifi6E.....if you decide to get a wifi 6 router now they aren't wifi 6E compatible  as it requires a new antennae/ rf frontend .....it will probably be a few months before we see wifi6E capable routers.....

Seasoned Contributor

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....

I wish all the router manufacturers had interactive demo's like that of their user interfaces......I'd almost buy a router based upon how pretty the gui is...lol......
Sharer

Re: SB6190 Modem consistently gets 250Mbps speeds on 400Mbps service - not sure why....


@rocketjetz wrote:

Just for reference the wifi alliance just annouced 6Mhz on wifi6 calling it wifi6E.....if you decide to get a wifi 6 router now they aren't wifi 6E compatible  as it requires a new antennae/ rf frontend .....it will probably be a few months before we see wifi6E capable routers.....


Good grief... as if the market space wasn't crowded enough already.  Getting to be like shopping for a graphics card.