Highlighted
Not applicable

Not getting the download speed I'm paying for.

I'm currently paying for 400mbps and I'm only getting 174.23/10.81. I have the Technicolor TC8715D modem/router. How can I improve the speeds? I ran the test wired.
6 REPLIES 6
Lead Moderator

Re: Not getting the download speed I'm paying for.

I would encourage you to check out this post and post what you can. 

 

DATA-TO-POST-TO-GET-HELP-FROM-THE-COMMUNITY

 

Regards,
Julia R.
Spectrum-Social Media Customer Care
Lead Moderator-Community Forums

Spectrum Employee

Re: Not getting the download speed I'm paying for.

The technicolor gateway is not rated for the ultra 400. It only has 16 channels on the modem. You will need to get the Arris TM1602AP2 that has 24 channels to get the higher speed. But it wouldn't hurt to get a snapshot of your signal strength and correctable/uncorrectables to see the health of the signal. I just recently upgraded my home service and had to get new eq. You can call in to either get it shipped to you, or pick up from the store. Make sure you don't have any lose connections, unnecessary splitters, or really long runs of coax.
Not applicable

Re: Not getting the download speed I'm paying for.

Yea I bought my own modem and router to figure that out. Don't know why I wasn't told this when I purchased the service and going to send me something that isn't compatible with the service.
Not applicable

Re: Not getting the download speed I'm paying for.

But my upload speed is far too low only getting 10mbps upload speed with 400mbps download. From what I read it says to update firmware but it says I can't update it manually. Do I need TWC to do that or do I need to go through netgear?
Helper

Re: Not getting the download speed I'm paying for.

Firmware is updated automatically by Spectrum. Netgear can't do it, customer service can't do it, and tech out in the field can't do it.

Proven Sharer

Re: Not getting the download speed I'm paying for.


@Jmarituajrwrote:
But my upload speed is far too low only getting 10mbps upload speed with 400mbps download. From what I read it says to update firmware but it says I can't update it manually. Do I need TWC to do that or do I need to go through netgear?

You have already said that you measured your download speed at 400 Mbps, which is proper for your package.  Please answer a few quick questions so we can help you:

1) What is your ZIP Code? 

That lets us find the upload speed for the 400 package in your area.

 

2)  What upload speed did you expect to have with your 400 package?

HINT:  The answer for 400 down is NOT going to be 400 up.

 

3)  You said the model number of your present modem is Technicolor TC8715D.

Did you buy it yourself or get it from Spectrum?

 

4)  Where are you reading about a need to update firmware?  As others said, Spectrum will push out the latest version received from TC that Spectrum has tested and approved.