Not applicable

New to Spectrum and keep having to reboot router

Hi all,

I just got the Spectrum Ultra 400 internet plan and picked up the modem & wifi router.

I am happy with the wifi speed from the Sagemcom Wave 2 RAC2V1S router that is connected to the Technicolor E31T2V1 modem.

Problem is the router drops wired and wifi connection quite often and I have to reboot it and all is good until the next time. I do not have to reboot the modem.

Any suggestions to fix or do I just get another one from them......Spectrum tech support is useless.

I can always use my netgear router but it is an older model and would prefer not to buy another atm.

 

Thank you

4 REPLIES 4
Helper

Re: New to Spectrum and keep having to reboot router

Have you tried direct connecting a computer to the modem to see if the connection is maintained?  This may not be a router problem but rather a signal problem...ie. loose connections, damaged coax, too many splitters, etc.

Not applicable

Re: New to Spectrum and keep having to reboot router


@reds91185 wrote:

Have you tried direct connecting a computer to the modem to see if the connection is maintained?  This may not be a router problem but rather a signal problem...ie. loose connections, damaged coax, too many splitters, etc.


My Mac Pro is directly connected to the router. The same setup (cables etc) with my old netgear router connected to the modem has no issue.

Proven Sharer

Re: New to Spectrum and keep having to reboot router

So ... your Mac works fine with your Netgear router, but not with the Sagemcom that Spectrum provided you?  Tell Spectrum that their router is defective and make them exchange it for a different model unit.  You are not the first Spectrum subscriber to complain about the Sagemcom routers.

Not applicable

Re: New to Spectrum and keep having to reboot router

Just went ahead and have them switch it out........they gave me the Askey RAC2V1K this time.

Seems to be working ok so far. This one has a different interface on the router log in page.

It has VPN too under security..............gonna see if I can add my NordVPN to it (have to find out if it will work).