Motorola MB7420 - corrupt firmware?

I bought this modem from Amazon 11 months ago, and it has performed superbly....until last night, when I suddenly lost internet connection.  As I usually do before calling ISP tech support, I attempted to reboot the modem.  (To show how well this modem has worked, I've only had to reboot it twice, after power outages!) wouldn't reboot.  All the lights on the modem came on, steady green/amber.  It didn't matter if I tried to reboot the modem via the power button or by unplugging/replugging the power cord.  The only way I could get it to properly reboot was by accessing the reset switch.


Being a glutton for punishment, I decided to try to reboot the modem again, just to see if this was a one-time glitch.  It wasn't.  And the reset switch didn't help this time.  Only by logging into the modem settings and selecting restore factory defaults was I able to get the modem up and running again.


I called Motorola Networking tech support, and the specialist I spoke to said the modem would have to be replaced because of 'corrupt firmware'.  He said this happens a lot with these particular modems.  Since firmware updates are handled by the ISP, I think he was kind of implying that Spectrum was the culprit.


Has anyone else had similar symptoms with the MB7420?  And was it firmware-related?


Re: Motorola MB7420 - corrupt firmware?

anything with a Motorola logo, not Arris is obsolete and there's little to no support on them.

If you did a factory reset and it now works, it's fixed.

Yes, bad provisioning could have been sent to it or a corrupt firmware updayte. You needed to post the log before you reset it to see what went wrong.

also post the present signal level page


Can't help any further.