Spectator

Can't get 200 mbps with Realtek PCLe GbE HP laptop

At one time I was getting 300+mbps service from Spectrum and then went back to basic which was 100 mbps at that time.  Now that the basic service is 200 mbps I found I've never been able to get more 110 or so with the modem (m87420) connected directly from the street line.  So I had a Spectrum tech out today and he determined that I can get 200+ mbps right up to my hp laptop from my router so signals to up to the computer are capable.  So I'm stuck.  I have a Realtek PCLe GbE controller and was able to update the driver for that from the Realtek site today (10.36.701.2019), running windows 10 latest and set for 1 gbps full duplex.  Yet I only get 110-120 running speedtest and 130-140 running fast.com on my laptop.  What next?  Any ideas?  At this point I'm ready to call it quits and live with what I have.  Thanks

7 REPLIES 7
Spectator

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

I guess I have my own resolution and wanted to share it.  I downloaded a free program called SG tcp optimizer and used its optimize settings.  Wow is all I can say.  I now have 230-240 mbps with a hard wire from my router and 150-160 mbps from wi-fi,  I know enough to set things like wireless speed, speed of gigs hard port, dns server, etc,  basic settings,  I am not sure what was set so out of wack with my computer.  I had 300 mbps service a few years back with this exact hardware and typically had 340 mbps so I don’t understand what when wrong or what the optimizer fixed but very happy with the outcome.

 

Sharer

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

Keep a shortcut to TCP Optimizer handy. Windows has developed a nasty habit of mucking up TCP/IP with Windows Updates.

Just need to run it as admin, click to set everything to defaults again, apply, and reboot.
Highlighted
Spectator

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

Thanks, yes ran it as admin.  I wonder what could have been so screwed up to cut my speed in half?  There must have been one major setting.  I did have the speed set to 1 gig full duplex on the hard line and was even using the 5 mHz AC on the router, which helped WiFi some but the optimizer really boosted things.  Maybe I'll reset it and do it again to pay more attention to what it changed.  Of course the Spectrum tech didn't have a clue and is not allowed to go further than the wire to the computer.

Helper

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop


@fbacher wrote:

...

 Of course the Spectrum tech didn't have a clue and is not allowed to go further than the wire to the computer.


Nor do you really want a tech rooting around on your computer either.

Sharer

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

Mostly it is the receive window setting. Part of the flow control mechanics that basically limits how many packets it tries to grab with each transmit cycle. Normally it is dynamic and adjusts on the fly according to how smoothly data is flowing.

The most basic explanation... it kinda just goes wide open until a problem occurs and then it throttles back until the condition clears and it opens back up again. During some update sessions, it flips it to a static value (sometimes a couple other settings too).

Running that tool to set it all to defaults sets all the potential snafus back to their dynamic/auto-detect settings. Simpler then removing/reinstalling network stuff to fix it otherwise.
Proven Sharer

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

Yes, this is the third time a Win10 major update has been shown to cause the same problem.  Each user is always responsible for maintaining their own computing equipment and software.  You can't blame Spectrum for this one!  

Spectator

Re: Can't get 200 mbps with Realtek PCLe GbE HP laptop

No I was not blaming Spectrum at all.  I had them out because I took my modem and laptop out to the street connection and still could not come close to 200 mbps, only 110.  At that time it looked to me like the issue was either the cable to the house or my modem since my computer hardware had supported a 300+ mbps connection at one time a few years ago.  I knew that I had not many any changes to my system but didn't realize that either a windows update or the operating system could somehow slow down my system on it's own with changes that it would not reverse on it's own.  When Spectrum went to 200 mbps I was getting 100 prior to that and after that too.  I finally got around to asking them if they somehow didn't update my modem.  The tech was very thorough and checked everything out before he demonstrated that both the modem and my router was capable of 200 mpbs.  Maybe the SG Optimizer is something they should recommend to users but I can also see they might not want that liability either.  Fixing my system would have been beyond a savy user yet ignorant of TCIP inner workings like myself wihout the SG Optimizer.