Highlighted

Closed Caption stopped working on some channels

My cable box, an Explorer 8640HDC, recently stopped displaying closed captioning on some channels. Other channels are fine. Neighbors with Spectrum get closed captioning on channels I do not. Any ideas how to fix? Prefer not to replace box as I don't want to lose DVR recorded programs.

3 REPLIES 3
Highlighted
Trusted Helper

Re: Closed Caption stopped working on some channels


@MidwestSteve wrote:

My cable box, an Explorer 8640HDC, recently stopped displaying closed captioning on some channels. Other channels are fine. Neighbors with Spectrum get closed captioning on channels I do not. Any ideas how to fix? Prefer not to replace box as I don't want to lose DVR recorded programs.


Hi Steve,

Where are you located, and what channels are you missing the closed-captioning? What is your percentage of recorded DVR space? When did the problem start?

 

First Option: I would try a cold reboot of the box.  Power off the box and unplug it for about five minutes.  Power the box back up and see if closed-captioning comes back on those channels.

 

Second Option: Contact Spectrum's Accessibility Center for reports with this issue,  You will need your account number when you call, the affected channels with the closed captioning problems and your box make and model. That number is the following:

 

tel:1-844-762-1301

 

Third option: Call Spectrum Customer Care to set up a service call for a signal and drop line test.  Avoid rebooting any boxes, modems, or routers, for six hours prior to your service call, to avoid resets of the error codes. When the tech comes, tune to the stations that have closed-captioning problems. He will take a signal/line reading.  Let the tech now that you don't want to replace the box.  If your signals are bad, a new box will not do anything.  If your signals are good, you might need a new box.  But try those first two options first.

 

Satch

Highlighted

Re: Closed Caption stopped working on some channels

Reboot fixed it. I didn't think it would be so simple. Thanks!
Highlighted
Trusted Helper

Re: Closed Caption stopped working on some channels


@MidwestSteve wrote:
Reboot fixed it. I didn't think it would be so simple. Thanks!

Glad to help!

 

You can mark this issue as "Solved" than it goes into our solutions database.

 

Satch