Newcomer

RLC-1000 error code

A Spectrum service person just left and fixed a slow internet speed issue.  He replaced the modem.  My router is the same.

 

Now Spectrum won't work on my second tv where I use Roku.   It keeps asking for my sign in info which I enter correctly but never goes past that.

 

What's going on?

4 REPLIES
Helper

Re: RLC-1000 error code

You may need to reboot everything, including the modem, router, and the Roku. If that doesn't work you may need to delete the Spectrum TV app and reinstall.

Observer

Re: RLC-1000 error code

I have Roku.  My wireless and Roku work fine on everything EXCEPT the SPECTRUM app which works then disconnects and says it is unavailable. This happens several times something several times a day. Last night it was horrible and never reallly allowed me to watch a single program on Spectrum App.  However, even Free Speech TV came in sharp and fine.    The issue is the Spectrum App.

Spectator

Re: RLC-1000 error code

Here is what worked for me. I had the same error RLC-1000 and failure to authenticate with the Roku, asking for my login continualy. 

 

I was recently switched from TWC email servers to Spectrum's email servers. When I logged into my account on the Spectrum web site (the same one to check your bill) I got a message that my TWC email address was not verified. I clicked the link to verify my email, got the verification email and was verified. 

 

When I logged back into the Web page the verification warning was gone. Then I went to the Spectrum app on the Roku and low and behold it worked. Didn't have to reboot or anything.

 

Not saying this will work for everyone but if you still have an email account that was a TWC account, try verifying it with Spectrum.

Newcomer

Re: RLC-1000 error code

I tried to login to my account on Roku while I was visiting my son and got the RLC-1000 error; stating connect to Spectrum Internet.  Spectrum is not available in his area.  I also tried My Spectrum on phone while using his wi-fi and could not use app.  I don't have a ton of data on my phone and was told as long as I was logged on to wifi it should work.  Why am I not able to login and use the app when away from home?