Rookie

Can't sign in - Account sign in page no longer loads (script error) in Firefox with Windows XP

On October 25, 2017 I signed into my online  account and downloaded a statement.

Everything worked as it normally did in the past.

Two days later, on October 27, 2017 I used the same bookmark and I get the same page;

But I get the following error;
A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.
If I choose any of the options, stop script, debugg, or continue I get a blank page.
So I can no longer sign in to my account using Firefox 52.0.2
which is the latest version for Windows XP SP3.
 
Both of my PCs with that configuration are affected.
All of the other Spectrum sites work OK, such as support,  email and signing into this forum.
 

Chrome browser does work to load the account sign in page, but I had not normally used that browser.

3 REPLIES
Participant

Re: Can't sign in - Account sign in page no longer loads (script error) in Firefox with Windows XP

I think Spectrum needs work on this. It took several times over 3 days to login to the TWC/Spectrum account page. It's because of the changeover is my suspicion. When I finally reached my account in order to pay my bill, it was a new look & it took forever. Unfortunately same thing is happening with AT&T.  And whenever these things happen, it takes them a long time.  In the mean time if you need your account info, I would call(I know not the best). Hopefully the amount of your statements are the same, so you don't necessarily need to see the detail statement.

Expert

Re: Can't sign in - Account sign in page no longer loads (script error) in Firefox with Windows XP

Yup, Firefox has dropped support for XP and Vista. It still sorta works on some sites. Had a lot of interface issues a month ago, recently cleared up though.

 

Try using Avast Safezone if you don't want to run chrome (which has also dropped XP& Vista support)

 

Rookie

Re: Can't sign in - Account sign in page no longer loads (script error) in Firefox with Windows XP

 

MsRaye wrote:

Yup, Firefox has dropped support for XP and Vista. It still sorta works on some sites. Had a lot of interface issues a month ago, recently cleared up though.

 

Try using Avast Safezone if you don't want to run chrome (which has also dropped XP& Vista support)

 


True, but it worked fine 2 days before Spectrum changed the code on their account sign in page. Same version of Firefox when it worked and when it no longer works.

No problems with Firefox on any other website that I visit.