Newcomer

BTN2GO App not working for the past week

I'm a Spectrum customer in Westerville, OH (former TWC Digital).  I haven't been able to access content on BTN2GO app for the past week. 

In the past, the app listed  two choices for verification of my BTN TV subscription:

  1. Charter Spectrum
  2. TWC Spectrum

I would always choose "TWC Spectrum," enter my credentials, and there was never any problem watching BTN online. 

 

The app recently changed, and no nonger lists the "TWC Spectrum" option.  Every time I choose "Charter Spectrum" and enter my credentials, the app reflects a blue screen with the following message: 

  • "NO ACCESS!  This account has no access, please switch to another account."

After deleting and reinstalling the app on my iPhone several times, I finally called support on Monday, 11/13.  I spent 71 minutes on the phone with Spectrum tech support, and they couldn't figure it out.  I was told it would be escalated, and that I would hear from someone in the next 24-48 hours.  Six days later, it's still not working, and I've no response from Spectrum Support.

 

Has anyone else had this problem? 

1 REPLY
Lead Moderator

Re: BTN2GO App not working for the past week

Good afternoon.

 

I have tried with several test logins and am successfully able to login to Charter/Spectrum.

 

if you are choosing Charter/Spectrum on the App or just Spectrum on the website and are in a package that includes the channel you should be authorized.

 

Please contact our Social Media Customer Care team directly for assistance with 

this. it sounds like a permissions issue which can be looked into. 

 

 

 

 

Twitter: @Ask_Spectrum
Facebook: https://www.facebook.com/Spectrum

 

Regards,
Julia R.
Spectrum-Social Media Customer Care
Lead Moderator-Community Forums