Rookie

ASA 5506-X using PD and IPv6 Hint

i see there are some other forum users running the ASA platform to do prefix delegation.  posting a new thread to see if there's any new info out there or maybe together we can figure something out.  i'm running 9.8(2)33 and successfully pulling a prefix and delegating it to hosts using the inside/outside interface configs below:

interface GigabitEthernet1/1
nameif inside
security-level 100
ip address 172.16.15.1 255.255.255.0
ipv6 address TWC_pfx ::5:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server DHCP-lite
ASA5506-X# sh ru int gi 1/8
!
interface GigabitEthernet1/8
nameif outside
security-level 0
ip address dhcp setroute
ipv6 address autoconfig default trust dhcp
ipv6 address dhcp default
ipv6 enable
ipv6 dhcp client pd hint ::/56
ipv6 dhcp client pd TWC_pfx

 

With the above i'm successfully getting a /56 and am delegating a /64 ending in '5' to my inside subnet.  i've done numerous tests with the ipv6 dhcp client pd Hint command.  Hinting for a /60 seems to be ignorned, hinting for my last full prefix also seems to be ignorned as i get a /64.  hinting for a ::56 gets me a /56 every time.  

 

I think TWC/Spectrum are definitely processing the hint requests but are doing the following based on my many tests:

::/64 hint - /64 seems to be default anyway, this functionally has zero impact

::/60 hint - ignored, i get a /64 every time

::/56 hint - i seem to get a /56 every time

2604:2000:22c0:f5::/56 hint - (one of my assigned prefixes) - ignored, i get a random prefix and a /64

2604:2000:22c0:f500::/56 hint - still ignored, i get a random prefix and a /64, just playing with the syntax here keeping the trailing two zeroes which are 'mine' in a /56

 

The interface will take multiple hints and i've experimented with that too.  simiar results as above - they'll take a /56 hint but basically drop everything else.  

 

Anyone have any luck getting the same prefix repeatably?  

 

Still working on assigning DNS servers through the ipv6 nd other-config-flag statement on the inside interface and the following:

 

ipv6 dhcp pool DHCP-Lite
dns-server 2001:4860:4860::8888
dns-server 2001:4860:4860::8844

 

still no luck on that.  Hosts are using their v4 dns server only and while pulling quad A records they're still via v4 dns servers.  

 

 

 

 

 

 

 

5 REPLIES
Community Manager

Re: ASA 5506-X using PD and IPv6 Hint

@mtnhillsman

 

Sorry that none of our forums participants had input on this question. 

 

For assistance, we encourage you to contact our Social Media Customer Care team:

 

Twitter: @Ask_Spectrum
Facebook: https://www.facebook.com/Spectrum

Rookie

Re: ASA 5506-X using PD and IPv6 Hint

I appreciate your cusomer service type response but i can guarantee being a network admin at a large college unless someone puts me in touch with a network engineer at TWC to answer my questions my time will just be wasted.

 

Historically with TWC, or any other homeowner provider, the tech representatives are level one consumer support at best. the engineers don't talk to the end user.

 

it's life, i accept it. but I'm not going to waste my time unless i know i'll be given the opportunity to speak to a network engineer.

Helper

Re: ASA 5506-X using PD and IPv6 Hint


@mtnhillsman wrote:

I appreciate your cusomer service type response but i can guarantee being a network admin at a large college unless someone puts me in touch with a network engineer at TWC to answer my questions my time will just be wasted.

 

Historically with TWC, or any other homeowner provider, the tech representatives are level one consumer support at best. the engineers don't talk to the end user.

 

it's life, i accept it. but I'm not going to waste my time unless i know i'll be given the opportunity to speak to a network engineer.


You won't be able to speak to the network engineers.  Like you said, they do not speak to the end users.

Rookie

Re: ASA 5506-X using PD and IPv6 Hint

FWIW  i did get DNS assignment working with the folloiwng code:

 

ipv6 dhcp pool dnsonly
dns-server 2001:4860:4860::8888

 

interface GigabitEthernet1/1
nameif inside
security-level 100
ip address 172.16.15.1 255.255.255.0
ipv6 address TWC_pfx ::5:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server dnsonly

 

this IOS version seems a bit buggy.  if you configure the dhcp server entry on the interface before configuring the pool it will give you an error that the pool does not exist but configuring anyway.  you'll see the entry there but even after you configure the pool it will not work.  i had to remove all entries, go to a new pool name, configure that first and then the two commands you see on the interface and now my hosts get google's IPv6 dns servers.  

 

Hope this helps someone.  Anyone out there still trying to figure out how TWC/Spectrum deals with the hint please comment below any progress.  They wont help us, so we need to help each other.  

Highlighted
Not applicable

Re: ASA 5506-X using PD and IPv6 Hint

This post has helped me greatly with getting ipv6 going at my house.  I would love to hear how to preserve the PD delegated by spectrum as rebooting my ASA and having to re-ip interfaces isn't that fun.  I was thinking about getting a ASN and getting a subnet routed to me, but not sure if spectrum will allow this over consumer coax.