Newcomer

SLOW Samsung Digital cable DVR box

Anyone else having an issue with how slow the equipment is? I've used TWC in the past and then DirecTV and now I'm back with TWC and I don't remember ever having this issue. The equipment is either really cheap or really old. It's extremely frustrating.
4 REPLIES
Sharer

Re: SLOW Samsung Digital cable DVR box

I have a new Samsung non-DVR box and an old Motorola DVR box...for me the Motorola is way more responsive. I even prefer the iguide menu to the newer menu. 

Trusted Helper

Re: SLOW Samsung Digital cable DVR box


casematrix wrote:
Anyone else having an issue with how slow the equipment is? I've used TWC in the past and then DirecTV and now I'm back with TWC and I don't remember ever having this issue. The equipment is either really cheap or really old. It's extremely frustrating.

Greetings,

 

What is the model number of this box?  Has it always been slow?  How long have you had the box?  You may want to contact Spectrum to get a tech out to check this.  You might try a different model box, such as an Arris or Cisco.  I would first get a tech out just to make sure something else is not causing the slowdown.

 

Satch

Observer

Re: SLOW Samsung Digital cable DVR box

I turned in a Motorola DVR set top box about a month ago and received a Samsung set top box (no DVR). It is also extremely slow for me. It is so frustrating when I choose to use the On Demand features because with every press of the remote button to get through the selection process , I get the circle that goes round and round for approximately 30 seconds, then an error code then I can choose the option I want. It takes a good 5 minutes to finally watch the program I want On Demand. My Roku using the Spectrum App is much faster.

 

I rebooted the box this evening and this did not fix the issue. I will be calling for tech support tomorrow and post the solution after this gets resolved. 

Re: SLOW Samsung Digital cable DVR box

YES!
Samsung SMT-H3272. We have 2 of them. Maddeningly slow response to DVR buttons - play/ff/rev - at all times. Random delays moving through guide menus especially - info button, Up/dn, page up/down. Things got worse for the first box when we added the 2nd box in 2H2016 - maybe just coincidence with some firmware or network/vendor change on the back end. On demand menus, search and programming guide menus clearly worse on Saturday evenings, with described "working" graphic and eventual error codes, which indicates to me some kind of capacity issue on the tw/spectrum network side. Tech support told me that its a known problem in the vendor system for on demand, with no indication of fix.