Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

I just noticed it's working again for me (Los Angeles area). I've had a support ticket open with Microsoft Exchange Online for weeks trying to get forwarding to gmail working like I could with twc and have been checking every several days to see if they fixed the problem. So, at least for me and at least for now I can send email and foward to my gmail account.

 

220 Welcome to Road Runner. WARNING: *** FOR AUTHORIZED USE ONLY! ***
ehlo mail.domain.com
250-dnvrco-cmomta03 hello [108.185.42.24], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 30000000
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-STARTTLS
250 OK

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

Port 25 seems to be totally offline for me.  Connection disconnects as soon as it is established...

 

[wright@web2 postfix]$ telnet mail.twc.com 25
Trying 107.14.73.68...
Connected to mail.twc.com.
Escape character is '^]'.
HELO554 dnvrco-cmomta01 cmsmtp ESMTP server not available AUP#O-1000
Connection closed by foreign host.

Port 587 is only slightly better, I can supply a DNS name before it boots me:

[wright@web2 postfix]$ telnet mail.twc.com 587
Trying 107.14.73.68...
Connected to mail.twc.com.
Escape character is '^]'.
220 Welcome to Road Runner. WARNING: *** FOR AUTHORIZED USE ONLY! ***
EHLO mydomain.com
421 Service not available, closing transmission channel
Connection closed by foreign host.

None of my home systems are able to send any email, and this has worked for 10+ years.  There is obviously some major issue going on that Spectrum is refusing to acknowledge.

 

[wright@web2 postfix]$ traceroute mail.twc.com
traceroute to mail.twc.com (107.14.73.68), 30 hops max, 60 byte packets
 1  OpenWrt.lan (192.168.1.2)  1.142 ms  1.117 ms  1.092 ms
 2  * * *
 3  tge0-0-9.rdrktxaz01h.texas.rr.com (24.27.13.37)  738.507 ms  738.441 ms  738.460 ms
 4  agg32.ausutxla01r.texas.rr.com (24.175.43.235)  10.255 ms  11.088 ms  11.060 ms
 5  agg22.dllatxl301r.texas.rr.com (24.175.41.46)  20.953 ms  22.041 ms  20.923 ms
 6  66.109.1.216 (66.109.1.216)  22.655 ms bu-ether14.dllstx976iw-bcr00.tbone.rr.com (66.109.6.88)  24.145 ms 66.109.1.216 (66.109.1.216)  18.842 ms
 7  be7.ar3.pkv01.tbone.rr.com (66.109.10.97)  31.970 ms  23.849 ms  33.546 ms
 8  be3.ar1.pkv01.tbone.rr.com (66.109.10.103)  27.501 ms  32.990 ms  33.064 ms
 9  66.109.6.219 (66.109.6.219)  32.200 ms  39.237 ms  31.298 ms
10  76.85.224.14 (76.85.224.14)  32.349 ms  34.376 ms 76.85.224.18 (76.85.224.18)  34.372 ms
11  * * *
12  * * *
13  * * *
14  * * *
15  * 76.85.224.18 (76.85.224.18)  29.623 ms !X *

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

Stopped working again yesterday (10/30). I can also confirm port 25 is completely offline. Port 587 is again dropping the connection after the ehlo command. This is getting ridiculous. You guys should check out some of the deals FIOS has going...that's what I'm looking into at this point.

Highlighted
Spectator

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

I spoke to someone there two days ago, and they (eventually, reluctantly) mentioned an internal ticket #219218, apparently affecting anyone using mail.twc.com.

 

At first, I figured Outlook was acting up in some way, but then I realized I couldn't send from my mobile device either...

Proven Sharer

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel


@dhearn wrote:

I spoke to someone there two days ago, and they (eventually, reluctantly) mentioned an internal ticket #219218, apparently affecting anyone using mail.twc.com.

 

At first, I figured Outlook was acting up in some way, but then I realized I couldn't send from my mobile device either...


Are you sure your mobile device is locked to WiFi using your Spectrum connection when you can't connect to Outlook? 

If you have the same difficulty while accessing Outlook over your mobile device, it's not a Spectrum connection problem. 

 

Spectator

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

karlbeckman, I was speaking about Outlook 2010 in Microsoft Office.  The mobile device has nothing to do with that.  However, good point!   I tried from my mobile device when I was (absentmindedly) on wifi at home, so of course I couldn't send from the mobile device either!  Works fine on 4G.

 

On the residential Spectrum connection:

MS Outlook 2010 client - nope!

Linux server - nope!

Android device on wifi - nope!

 

My interrupted connection to mail.twc.com and the ensuing SMTP 421 error doesn't really care which client I'm on, now does it!  So yeah, same as everyone else, issuing EHLO [anything], manually or otherwise, just gets me disconnected on the residential Spectrum connection.

Spectator

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

Spoke to a fellow named Eric in escalated support.  He's opened a ticket SCI000000058614 based on the information I sent him:

 

-A link to THIS forum

-Output from my linux box:

 

[xxxxxx]@wi.rr.com... Connecting to mail.twc.com port 587 via relay...
220 Welcome to Road Runner. WARNING: *** FOR AUTHORIZED USE ONLY! ***
>>> EHLO [xxxxxxxxxx].us
421 Service not available, closing transmission channel
>>> QUIT

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

Thanks dhern! Maybe, just maybe, this might actually get past customer service/help desk to the actual IT staff...then perhaps we have a chance of getting it resolved.

Spectator

Re: mail.twc.com SMTP: RECEIVED: 421 Service not available, closing transmission channel

This just started working for me around 11pm CST.  Anybody else having better luck?

 

They called me yesterday asking for more information (which was already in the ticket).  Didn['t get any updates today, but realized a test message in my outbox was now gone...

 

-David

 

[root@www dhearn]# (echo subject: test; echo) | /usr/sbin/sendmail -v -Am -i xxxxxxxxxxx@xxxxxcom
xxxxxxxxxxx@xxxxxcom... Connecting to mail.twc.com port 587 via relay...
220 Welcome to Road Runner. WARNING: *** FOR AUTHORIZED USE ONLY! ***
>>> EHLO www.xxxxxxxxxx.xx
250-dnvrco-cmomta02 hello [xx.xxx.xxx.xxx], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 30000000
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-STARTTLS
250 OK
>>> STARTTLS
220 Go ahead
>>> EHLO www.xxxxxxxxxx.com
250-dnvrco-cmomta02 hello [xx.xxx.xxx.xxx], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 30000000
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 OK
>>> AUTH PLAIN cm9vdABkaGVhcm5Ad2kucnIuY29tAEhlY3RvcjczMg==
235 2.7.0 ... authentication succeeded
>>> MAIL From:<dhearn@xxx.xxxxxxxxxx.xx> SIZE=15 AUTH=dhearn@xx.xxxxxxxxxx.xx
250 2.1.0 <dhearn@www.davidhearn.us> sender ok
>>> RCPT To:<xxxxx.xxxxx@xxxx.com>
250 2.1.5 <xxxxx.xxxxx@XXXX.com> recipient ok
>>> DATA
354 OK
>>> .
250 2.0.0 KGJQg0n2bXEleKGJSgpr3T mail accepted for delivery
xxxxx.xxxxx@XXXX.com... Sent (KGJQg0n2ZXEleKGJSgpr3T mail accepted for delivery)
Closing connection to mail.twc.com
>>> QUIT
221 2.0.0 dnvrco-cmomta02 cmsmtp closing connection
[root@www dhearn]#