Highlighted
Rookie

TWC email Server Security "None"?

TWC Roadrunner Email Server Security on

Nexus 7 (2013) Android 6.0.1

Droid Mini (Verizon) Android 4.4

 

On both devices, both Incoming (POP port 110) and Outgoing (SMTP port 587) Server settings for @neo.rr.com email show Security Type as "None".  Choosing SSL/TLS alone or with        " Accept all Certificates" gets "Cannot connect to server". Account Setup instructions say to set Server Security Type as "SSL/TLS Accept All Certificates".

My User Name and email address are as originally assigned years ago, as is my Master Password.  If these are compromised, what's to keep email secure?

 

Everyone's Tags (1)
5 REPLIES
Spectrum Employee

Re: TWC email Server Security "None"?

My apologies for the issues getting your e-mail set up, @MikeG.  Have you tried the IMAP settings below to see if that makes any difference:

 

IMAP settings:
Account Type: IMAP
Incoming Mail Server: mail.twc.com
Incoming Server –IMAP port: 143
Outgoing Mail Server (SMTP): mail.twc.com
Outgoing Server – SMTP port: 587
Inbound & Outbound User Name: Enter full email address
johndoe@[division].rr.com
johndoe@roadrunner.com
johndoe@twc.com).
Inbound & Outbound Password: Email Password (same as Web Mail)
SMTP Server Requires Authentication: Checked
 
Thank you for your participation in the Forums!

 

Regards,
Jeremiah S.
TWC-Social Media Customer Care
Moderator - TWC Community Forums

Check out the community guidelines here
Rookie

Re: TWC email Server Security "None"?

Jeremiah,

Thanks. Before I follow your instructions, I want to be sure I was clear about my concern. I access TWC (Roadrunner) email through TWC wireless modem. The email address is xxxxx@neo.rr.com).  I have no problem accessing email. My question is about security.

When I go to my Time Warner Email - Settings - Account  - Server Settings, both Incoming and Outgoing Settings show  "None" under Security Type. Is this OK?

If I select anything else (SSL, SSL/TLS, etc..) and click Done, I get "Cannot connect to Server". My Username and Password are both shown and correct as are POP and SMTP servers.

Please confirm for me that this is clear and whether i should follow your instructions for better email security,  I don't want to attempt to fix something that's not broken.

Thanks again. 

 

 

 

 

Spectrum Employee

Re: TWC email Server Security "None"?

At this time, SSL/TLS encryption is not supported which is why those errors have occured.  My apologies I did not mention that in my original response.

 

Thank you for your participation in the Forums!

 

Regards,
Jeremiah S.
TWC-Social Media Customer Care
Moderator - TWC Community Forums

Check out the community guidelines here
Observer

Re: TWC email Server Security "None"?

It's 2016 and TWC mail still doesn't have basic security for its email servers. That's unbelievable. This was standard as of 15 years ago with most any internet/email hosting company. It's shameful.

Newcomer

Re: TWC email Server Security "None"?

I agree this is a huge security vulnerability and  to be addressed NOW !