Newcomer

Re: Is outgoing smtp server mail.twc port 587 down?

Same situation for me.  Have been on with tech. support a couple of times, actually got them to admit that they had the problem, but could not offer any time frame for a fix.  I have been unable to send out mail from Outlook for over two weeks.  Tried Thunderbird with the same issues.  This is totatlly unacceptable performance from a company that charges me as much as they do for their services.  Guess I am going to have to look at atlernative services 

Rookie

Re: Is outgoing smtp server mail.twc port 587 down?

After two weeks, the outgoing mail problem was finally fixed in the Troy, NY, region.

 

I successfully sent messages back and forth to my home and business accounts using outgoing servers smpt-server.nycap.rr.com and mail,twc.com and well as the private server my business rents space on.  No setting changes were made. If Spectrum tells you it's your problem, don't believe them.

Highlighted
Established Sharer

Re: Is outgoing smtp server mail.twc port 587 down?

Just don't expect it to stay fixed.  This is a good time to migrate to another e-mail service, such as Gmail or Outlook.com and free yourself from the pain of Spectrum's inability to manage their e-mail servers and webmail.

Participant

Re: Is outgoing smtp server mail.twc port 587 down?

Have to reinforce what RickE advised. I struggeled with several email issues with WTC/S over the last year and more. During that time there were many trouble shooting sessions, fingerpointing and promises that it would be fixed, About 6 months ago I switched providers (For me because I use MS Office Pro Plus) to Outlook.com. I forwareded all mail comming into my rr.com addy on to my Outlook addy and after moving folders in Outlook from the rr.com account to the Outlook account I deleted the rr.com account out of Outlook. Have been trouble free since then. Same can be done with any other provider and email app. I could continue to complain or do something about it myself.  Good luck

Re: Is outgoing smtp server mail.twc port 587 down?

Thanks. That is a good idea - and here's another twist...

I already had  my Google account set up in Thunderbird.

So under 'Options'  'Account Setting'  I edited the Outgoing Server (SMTP) list to remove all my TWC accounts and set the the Google SMTP server as the default. All is well again - finally.