Newcomer

Unable to Connect Google Home Mini

 AT&T worked fine plug and play. but Not that I just moved over to Spectrum my 3 google homes are not working. They can not connect to the WIFI.  I talked to Spectrum 3 times, and asked them how to change setting in their own routers and no one in this company seems to have any clue on there own routers.  Please post a solution once you have it. 

1 REPLY
Highlighted
Lead Moderator

Re: Unable to Connect Google Home Mini

Have you reviewed set up steps we have listed on our website?

https://www.spectrum.net/support/internet/google-home-wifi-connection/

 

Make sure you have the following system requirements before setting up your Google Home or Google Home Mini device:

  • The latest version of the Google Home app 
  • The latest version of Google app (Android only)
  • A Google account
  • Access to a secure WiFi network
  • An Android or iOS mobile device
Note: Your mobile device’s display language must be set to English (U.S.) to set up Google Home. This can be changed in your device’s settings menu.

 

Setting Up Google Home

 

  1. Make sure your Google Home device is plugged into a power outlet and turned on.
  2. Make sure your mobile device is connected to your In-home WiFi network.
  3. Download and open the Google Home app on your mobile device.
  4. Select Accept to agree to the Terms of Service and Privacy Policy.
  5. Follow the onscreen instructions to connect your Google Home device to the Google Home app.
  6. When prompted, select Play Test Sound to confirm the connection is successful. Select I Heard the Sound to proceed.
  7. Assign your device to a room for easy identification.
  8. Choose the wireless network you'd like to connect your Google Home device to and enter your password.
  9. Once the connection has been established, select Continue to proceed.
  10. You’ll be prompted to sign in to your Google account. Follow the remaining onscreen instructions to complete setup.

 

Found on the Google Site

I can't establish a Wi-Fi connection

If you're able to see your Wi-Fi network listed in the Google Home app during setup, but you can't connect your Google Home device to the network and complete the setup process, try these steps.

Initial checklist

  1. The Google Home device is powered on and plugged into a wall outlet.
  2. Make sure you're using the correct password. Try re-entering it again. 
  3. On your mobile setup device, make sure:
  4. Make sure the Google Home device is within 15-20 ft (4-6 m) from the Wi-Fi router.
  5. Has the Google Home been connected to this network before?
    • Were there any recent changes to your network?
      • Did your ISP (Internet Service Provider) upgrade or make any changes to your router/modem?

General troubleshooting 

Step 1. Reboot the following devices:

  1. Wi-Fi router

    1. Unplug the power source for ~1 minute and plug back in.
    2. Note for Netgear Nighthawk users: If you're unable to set up using the Netgear Nighthawk router, then you may need to: 
      • Disable Access Control
      • Enable the option "Allow guests to see each other and access my local network" in the "Guest Network Setup"
  2. Google Home device
    1. Disconnect the power cable from the Google Home device.
    2. Reconnect power cable back into the Google Home device.

Step 2. Turn Wi-Fi on and off on the mobile setup device.

Step 3. If you have a dual band router, try setting up Google Home on both the 2.4GHz and 5GHz bands.

Still need help? Contact a Google Home specialist at 1-855-971-9121.